Wordfast Classic in Windows 10 leaves double space when you ctrl-delete a word
מפרסם התגובה: Chris S

Chris S  Identity Verified
הממלכה המאוחדת
משוודית לאנגלית
+ ...
Jan 24

Just upgraded to Windows 10.

In Wordfast Classic, but not in Word itself, it now leaves a double space when you ctrl-delete the word after the cursor, rather than just one space. How do I stop this please?


 

Andrzej Mierzejewski  Identity Verified
פולין
Local time: 13:28
מפולנית לאנגלית
+ ...
Is this a problem? Jan 24

Looks like WF only removes the word. The space behind it remains and joins the one standing before the removed word. That's why you see double spaces.

No idea how to prevent but does it really cause any problem? Once you have finished translating and you're in the correction and edition phase, you can remove all double spaces with a single operation: find all double spaces and replace with single spaces. Like when you write anything in an editor.

HTH


neilmac
 

Jean Lachaud  Identity Verified
ארצות הברית
Local time: 07:28
מאנגלית לצרפתית
+ ...
... Jan 24

This appears to be a "feature" of the recent versions of WfC (What version of WfC are you using?), rather than Windows 10.
WfC disables Word's Smart Copy/Paste in segments. As you have noted, Smart Copy/Paste works fine when Wf is inactive. It didn't use to.

This can be verified by going to File | Options | Advanced | Cut, Copy and Paste | Settings, and re-checking the "Adjust sentence and word spacing automatically" box. When returning to the segment, Smart Copy/Paste will w
... See more
This appears to be a "feature" of the recent versions of WfC (What version of WfC are you using?), rather than Windows 10.
WfC disables Word's Smart Copy/Paste in segments. As you have noted, Smart Copy/Paste works fine when Wf is inactive. It didn't use to.

This can be verified by going to File | Options | Advanced | Cut, Copy and Paste | Settings, and re-checking the "Adjust sentence and word spacing automatically" box. When returning to the segment, Smart Copy/Paste will work, but will re-disabled in the next segment. In addition, Pasting similarly does not insert a space when the cursor is on the last letter of a word.

Very annoying indeed.


Chris S wrote:

Just upgraded to Windows 10.

In Wordfast Classic, but not in Word itself, it now leaves a double space when you ctrl-delete the word after the cursor, rather than just one space. How do I stop this please?


[Edited at 2020-01-24 14:22 GMT]

[Edited at 2020-01-24 14:22 GMT]
Collapse


 

Chris S  Identity Verified
הממלכה המאוחדת
משוודית לאנגלית
+ ...
TOPIC STARTER
Yes it is a problem :-) Jan 24

It’s the latest version. Yes it is a problem and yes it is really annoying!

The whole reason I use WFC is that I know how it works and I can edit my dictation quickly and efficiently using keystrokes.

Having to delete these extra spaces is a pain. I could get used to hitting delete twice every single time, but then it would mess up my editing in other applications.

Thanks for your input. I thought it might be a setting but I’d better report it to the de
... See more
It’s the latest version. Yes it is a problem and yes it is really annoying!

The whole reason I use WFC is that I know how it works and I can edit my dictation quickly and efficiently using keystrokes.

Having to delete these extra spaces is a pain. I could get used to hitting delete twice every single time, but then it would mess up my editing in other applications.

Thanks for your input. I thought it might be a setting but I’d better report it to the developer as a bug.

[Edited at 2020-01-24 18:03 GMT]
Collapse


 

Chris S  Identity Verified
הממלכה המאוחדת
משוודית לאנגלית
+ ...
TOPIC STARTER
Sorted! Jan 27

I contacted Wordfast HQ and within a couple of hours they sorted it in new version 8.19.

Impressive service!


Dan Lucas
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Wordfast Classic in Windows 10 leaves double space when you ctrl-delete a word

Advanced search


Translation news related to Wordfast





Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



ProZ.com Headquarters
235 Harrison Street Mail Drop #22
Syracuse, NY 13202
USA
+1-315-463-7323
ProZ.com Argentina
Calle 14 nro. 622 1/2 entre 44 y 45
La Plata (B1900AND), Buenos Aires
Argentina
+54-221-425-1266
ProZ.com Ukraine
6 Karazina St.
Kharkiv, 61002
Ukraine
+380 57 7281624
מתרגמים אלו מתאמים את תרגום ProZ.com ל-עברית

Team Coordinators: Addie Ney
נא שים לב שלא כל האתר תורגם. לוקליזציית האתר היא תהליך המתבצע בכמה שלבים, כאשר תחילה מתורגמים האזורים הפעילים ביותר שבאתר. אם אתה מוצא שגיאה בתרגום של חלק כלשהו באתר שכבר תורגם, נא עדכן את אחד ממתאמי הלוקליזציה שלעיל.
לקבלת מידע אודות האופן שבו באפשרותך לסייע לתהליך הלוקליזציה של האתר, אנא לחץ כאן.

Forums
  • All of ProZ.com
  • חיפוש מונח
  • עבודות
  • פורומים
  • Multiple search